A recent update to Internet Explorer is taking a major step towards making the browser more secure.

There’s a new security measure called out-of-date ActiveX control blocking. ActiveX controls are applets that let a website show you content like videos and games. What this will mainly effect is Java – Java is used to run many games and it is the gateway through which the majority of attacks come in Internet Explorer.

Hackers set up web pages with bugs that keep an eye out for old versions of Java and attack if they happen to detect it.  Microsoft says Java exploits accounted for up to 98% of exploit kit detections in 2013. Many of these attacks can be blocked if people keep current with the latest Java updates, but users are often not-so-good about that.

Out-of-date ActiveX control blocking won’t stop you from using part of the web page that are up-to-date, but it will stop you from loading outdated controls. You should be given the option to update to newer, safer version of the outdated control.

This update applies to Windows 7 SP1 for  versions 8 through 11 of Internet explorer and for Windows 8 and 8.1  Of course, there’s no update for Windows XP since support stopped back in April.

If Java is blocked, you should see a notification like this:

On some systems you can choose to run the out-of-date app, but you may find that if you’re in a managed environment like work, school or the library, you will not have permission to do that.

You’ll also receive a notification if a web page tried to launch an outdated app outside of Internet Explorer. 

The blocking won’t being until September 9. After that you’ll see messages for the following versions of Java ActiveX controls:

  • J2SE 1.4, everything below (but not including) update 43
  • J2SE 5.0, everything below (but not including) update 71
  • Java SE 6, everything below (but not including) update 81
  • Java SE 7, everything below (but not including) update 65
  • Java SE 8, everything below (but not including) update 11

~ Cynthia